Pentax Users - New K-r - Display Issues?

Discussion in 'Photography Board' started by ilovepete, Jun 4, 2011.

  1. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    I just got my K-r and have been experimenting with pics in auto mode for now. I am having an issue though and I've gone through the entire operating manual and can't find anything on this.

    In live mode, playback mode, and video mode (anything using the screen) the colors seem completely off for me. For instance, black will be a neonish blue at times (almost like when you do a negative image), and some other colors are way off on the display as well. This even happens when I'm switching picture modes, the example pictures for things like portrait, macro, etc. are way off. I found this odd, especially since the images on the computer come out fine from my memory card, they look normal and the colors are accurate and everything is fine.

    After trying everything I could think of and reading the manual, I began searching K-r reviews. In some of these reviews, I noticed pictures of the displays on their K-rs and mine don't look anything like this in the menus. For instance, like in these pictures:
    http://www.photographyblog.com/reviews/pentax_kr_review/product_images/

    If you go down to the one with the info screen, just to make it easy, my info screen looks completely different. It has all the icons, but there are no blue boxes around them at all. They are black. In fact most of the screen is black except the icons. I also have a white rim around the outside of the screen that almost fades as it goes from the edges. Also my four way controller, inside the little "arrows" on the screen, it is not blue, it is black.

    Does anyone have any ideas on how to fix this or did I get a bad screen? I have tried everything I can think of. Otherwise I am happy with this camera's performance but with how difficult it makes trying to see things in playback (trying to see if I caught a smile or my child's eye's open, etc., which I cannot tell with this issue), this may be a deal breaker for me.

    Thank you in advance for any help, and I am sorry this is so long!

    Oh and here are some pictures of what it is doing:

    [​IMG]

    Info screen to show it is not the same as it shows on all the reviews ive read
    [​IMG]

    Menu screen
    [​IMG]

    A photo taken, this is the playback view, these colors are not right, this is exactly what it looks like on my screen
    [​IMG]

    These are some of the pic modes, see you can tell even in these pics that the colors/display is off and you can see some of the hazing around the edges, too. They look exactly like this on my screen or worse.
    [​IMG]
    [​IMG]
     
  2. Avatar

    Google AdSense Guest Advertisement


    to hide this advert.
  3. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    Just got your pm, so I figure I will just reply here. That is not normal or anything you are doing wrong. I would try a hard reset before contacting service, but if that doesn't do anything I suggest requesting it to be changed out. You just got it, so you should be able to go through who you bought it from instead of Pentax service. The instructions to return it to factory condition (i.e. hard reset) should be in the manual. Doing that and still having a problem proves that it was not a setting you messed with. Also mention to the service rep that you tried it before calling.
     
  4. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    Well I tried the reset, that did not work. :(
     
  5. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    You should definitely call the store about this. If they try to tell you that you should deal with Pentax service, then you should complain.

    Don't get discouraged about it. There are always going to be some defective items with any consumer electronic. It also could have been dropped or damaged during shipment.
     
  6. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    They told me to return it, so I will. But now I am bummed because they no longer have the red one for me to exchange it for. :( I am not sure what I will do now as far as getting a replacement.
    And of course I hope the return goes smoothly, it's an online retailer so those are always questionable since you have to wait for them to process it and everything.

    Thanks again for your help.
     
  7. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    Do you have any idea if a firmware update could help this? I don't think so because I think it's actually the screen but I thought I'd ask. I have it all packed up to ship back so I didn't want to go to all the trouble to do it if there is no chance it would help, but thought it was worth asking about.
     
  8. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    I doubt it would help. This sounds like physical damage during shipment to me. It was shipped at least three times and sometimes boxes fall without being reported. As for color, i personally like the white ones as well. You can also ask how long of a wait for the red one.
     
  9. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    They said they weren't expecting any new shipments of them. I noticed even the Pentax store is out of red ones. Bummer! Anyway thanks again for all your help! :thumbsup2
     
  10. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    It is probably due to the earthquake. Everything out of Japan is getting behind. Don't know where you bought it, but have you looked at B&H and Adorama?
     
  11. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    They do have them, but they have them for way more than I paid for this one. The cheapest I've found it is $50 more. I originally bought it at buydig and had a coupon code as well.
     
  12. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    Yeah, that makes sense from them. They are good for prices, but the selection is not always that wide. I have bought off them before and they are honest. It probably doesn't have them, but double check their sister site, Beach Camera. They sometimes have different stock even though they are physically the exact same place.
     
  13. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    Yep checked them. I think I might just go with the white one, it's growing on me. :)
     
  14. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    There have been a few times I wished that I had gone with the white one. Although I did have an interesting experience with my red one. My DW and I got to attend the Last Tour to Endor party last summer at the studios. More than once that night I got asked if my camera was a special edition "Rebel Alliance" or "Darth Maul" one. I bet I sold about ten or more cameras for Pentax that night. Although, a white "Storm Trooper" model might have excited them even more. :darth:
     
  15. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    That is too funny. LOL I can't seem to get buydig.com to send me a return shipping label. They keep saying they are sending it and I'm not getting it. So I still have this camera. Now they are closed until Monday. Really frustrating!
     
  16. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    That is surprising to hear about them. I hope they have not changed. As long as you have it and the end product is fine, go ahead and use it some this weekend to start getting familiar with the handling.
     
  17. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    OK I got the manager to finally send me a return label and got it sent off today. Now just have to figure out a replacement.
     
  18. disneyboy2003

    disneyboy2003 DIS Veteran

    Joined:
    Nov 15, 2008
    Messages:
    805
    Wow! It's about time they sent you a return label. This whole thing seems to have dragged on for longer than necessary. :sad2:
     
  19. ukcatfan

    ukcatfan DIS Veteran

    Joined:
    May 11, 2001
    Messages:
    5,268
    You know, this all disappoints me with them. I bought two cameras, a lens, and a few accessories from them and never had one problem. I even sent one thing back with no problem. Now that B&H and Adorama are pretty much matching them on prices, I am worried that their level of service might have dropped.
     
  20. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    Well to be fair, they were *trying* to send it but I was not getting it. I gave them 3 different email addresses. I was checking my spam. I was doing everything to try to get it. I finally had enough and told them they need to figure out some way to get this to me. I guess they fwded me to the manager and he sent the label while on the phone with me (as others had done, and it hadn't worked, but his came from his own email account, not the big one they were using). I got the label then and was able to print. So, it took a week. They were trying, but just not hard enough. It was disappointing, as I could already have my refund or replacement on the way by now. I just hope they don't run out of white ones by the time I get my refund or replacement. We'll see I guess. Just kinda bummed all the way around but I'm trying not to let it sway my view on Pentax. :) I thought the camera was nice just defective, unfortunately.
     
  21. ilovepete

    ilovepete DIS Veteran

    Joined:
    Aug 7, 2010
    Messages:
    1,868
    Now they are out of the white one, too. Maybe this isn't meant to be!
     

Share This Page