Fridge not working- advice please!

Discussion in 'Budget Board' started by jeankeri, May 24, 2008.

  1. jeankeri

    jeankeri <font color=darkorchid>I threw cartons of milk at

    Joined:
    Jul 6, 2003
    Messages:
    3,085
    So, my stainless steel GE Profile fridge is not working this morning. The internal temp reads 60 degrees :scared: . Fridge was bought in November, 2003. So, it's a little over 41/2 years old. Since we are in a holiday weekend I am not calling for a repairman to come before Tuesday. Has anyone had history with these fridges? Is it planned obsolesce, or possibly something fixable? BTW, the only stainless fridge that meets the specs of the one I have now (to fit in my kitchen) is the same model I currently have! And, even if I wanted to buy this one, Sears would not be able to deliver until July 29th!!! Current price- $1500! :sad2:
     
  2. Avatar

    Google AdSense Guest Advertisement


    to hide this advert.
  3. a1tinkfans

    a1tinkfans Spreading Some Pixie Dust Today!

    Joined:
    Aug 12, 2006
    Messages:
    9,053
    NO help here, sorry, just

    Sending you GOOD LUCK! Hopefully it can be repaired reasonably!
     
  4. Rigel Kent

    Rigel Kent Space Mountain Stampeder

    Joined:
    Sep 2, 2005
    Messages:
    118
    I like visiting http://applianceguru.com/

    Here's the generic advice:

    http://fixitnow.com/wp/2005/10/23/w...ing-up-refrigerator-warm-refrigerator-repair/

    There you'll find the generic basic steps:

    Is the condenser fan running and the condenser clean?

    Is the evaporator fan running?

    Does the evaporator itself look abnormal: either too much frost build-up or too little? (You have to take off the back panel inside the freezer to see.)


    (With some of those, there's also the very remote possibility: The light inside doesn't go off when you close the fridge door. I know, just wishful thinking.)
     
  5. melcan

    melcan Mouseketeer

    Joined:
    Jan 28, 2008
    Messages:
    169
    OI just had my GE fixed about a month ago. It is not a Profile but is in on the
    high end of the GEs. The Mother Board went out on it. The repair man came in, took a panel off the back popped another board in and $180.00 and 6hrs later. It was cooling perfectly.

    BTW my GE is about 5yrs old


    OK, so DH says it IS a Profile
     
  6. tikilyn

    tikilyn DIS Veteran

    Joined:
    Oct 24, 2003
    Messages:
    1,750
    I had an 04 Fridgeaire (I know I spelled that wrong) and the defrost timing board went out on it. That was a 250.00 repair bill. We we're told to unplug the fridge for a couple of hours so the thethingamajig(looks like a raditator) could defrost the ice off (sorry that so doesn't make sinse). Then it worked fine for a week or so.
     
  7. jeankeri

    jeankeri <font color=darkorchid>I threw cartons of milk at

    Joined:
    Jul 6, 2003
    Messages:
    3,085
    Thanks for all the advice. I unplugged it, left the doors open for 24hrs, then re-plugged it in. So far, so good. The person I talked to on the phone thought the freezer door may have been left open so the fan froze. :confused3 Hopefully it's all better now. :goodvibes
     
  8. melcan

    melcan Mouseketeer

    Joined:
    Jan 28, 2008
    Messages:
    169
    I think that's what happened to mine. I did't catch it fast enough and it ended up burning out. Also there is a panel on the back, that was VERY dusty, I was told to vacuum it off about once a month to keep the coils clean.. I noticed you have pets, I do too and there was so much dust, cat hair, and whatever else, you can emagine back there.

    Good luck, I hope yours turns out fine.
     

Share This Page