PDA

View Full Version : thursday night quest


cat_herder
06-08-2006, 07:56 PM
Is anyone doing this staff room quest.

I've been on it 15 minutes and can't find the answer to #2. Place that could burn you to find this gem.

I trid the forbidden temple, Ned's fire pit, the fire pit in the spell room, I can't think of any other place with fire that you could put a gem near.

terrijoy
06-08-2006, 07:59 PM
Try the dungeon

cat_herder
06-08-2006, 08:00 PM
Boy, you are smart. Thanks

Dashzap
06-08-2006, 08:05 PM
I am #46 in line (it is so nice to type a number...the vmk dictionary always confounds me on numbers!) and hope to actually get to do the quest tonight. Last few nights I haven't been able to get into the host events. :confused3

astrostan
06-08-2006, 08:29 PM
where's the first one and if you could the rest, lol

qruthie
06-08-2006, 08:38 PM
The first one is by the scary tree about half way down the side of the mansion building.

Where is the 6th one? The gem and blue monster.

Peacefully
06-08-2006, 08:41 PM
gem and blue monster is by monstro's mouth in storybookland

I searched around the Yeti far too long on that one. I even thought "How weird that they'd call him blue". bah.

astrostan
06-08-2006, 08:42 PM
what about 3?

Peacefully
06-08-2006, 08:45 PM
I'm done with it. If you tell me the clue, and not just the number, I'll try to tell you where it is if I remember.

astrostan
06-08-2006, 08:47 PM
find the skull in the skull.

Peacefully
06-08-2006, 08:50 PM
the skull on discovery island. Near the edge of the screen. I tried Forbidden Temple first, but that's the next one. You also go back to the Forbidden Temple room later.

astrostan
06-08-2006, 09:03 PM
this is a jewel of a place to start a lovely cruise.

Peacefully
06-08-2006, 09:07 PM
In the lower right corner of the jungle cruise game room. It's near a plant and a path, if I remember right.

hdmonkeybug
06-08-2006, 09:18 PM
was dropped when a spell was cast?

judimouse
06-08-2006, 09:29 PM
One hour for the quest.

Logged on, got in line, dc, logged on, got into room, started quest and game frozen, logged on, after two questions the game would freeze and I would have to log off and log back in.

For 21 questions I had to log in 12 times.

Why can't they fix vmk?

astrostan
06-08-2006, 09:33 PM
I got done with the quest in like an hour. Is that to long to get something?

Peacefully
06-08-2006, 09:47 PM
was dropped when a spell was cast?

If you haven't gotten it yet, it's by the throne at the bottom of the screen in the spell room in fantasyland.

Sorry, I got distracted for awhile and forgot about this thread.

I got done in 22 minutes, I think.

VMK_Princess_Chloe
06-08-2006, 09:55 PM
bazaar place for a skull???

VMK_Princess_Chloe
06-08-2006, 09:57 PM
nevermind i'm dumb.. lol those skulls are hard to see!


where is the crows nest?

astrostan
06-08-2006, 10:00 PM
Fantasyland in the sky

VMK_Princess_Chloe
06-08-2006, 10:08 PM
duh!! thanks! I did it in just under 30 minutes. Will probably still be like 800 or something.. lol!

Peacefully
06-08-2006, 10:37 PM
Has anyone gotten any prize notifications yet? The quest has been over for awhile, hasn't it? I haven't gotten anything.

edit: Nevermind, rank 275. Bah.

VMK_Princess_Chloe
06-08-2006, 11:00 PM
I just got dc'd so I'm logging in as we speak..


and the verdict is..... 325 ugh!!!!!!

no prize.. they should at least give a prize like a pirate treasure chair... they are cheap and you can buy them. Something for the effort! Goodness!

darkacre
06-08-2006, 11:33 PM
MY best finish was a hair over 8 minutes, and I finished in the 130s. Prizes ended at 105 (?)

SorcererDonald16
06-08-2006, 11:34 PM
I read up on this thread just before I started the quest, and a couple players in the game gave me tips when I said I was off to start it. But what helped me more than anything was using my 2 teleport magics. Never have tried it before, but it helped me out a lot. I was wondering before if that might be contributing to the insane times people put up, and I definitely think that's a factor. If people were racing you to the gem, you could just teleport over to it. If there was a walk that took 15 seconds, it would take maybe 3 or 4.

It has a recharge time of a minute I believe, so after you use the first one just type "Jump!" when you need to use the second one. Otherwise, it'll give you an error message if you just click on the wand and try to double click on the pin (even if your 2nd magic hasn't been used yet; I tried this out before I started the quest). So, between the answers here and a couple hints that were mentioned in the game (I believe they were also included in the ones mentioned here), I wound up with a time of 7:31. That was my first and only run through. I think I came in 86th, 13 places above where Inferno was. So close yet so far away, LOL! I won a buyable Jolly Roger flag, in case you're wondering.

SO... my conclusion is that besides the mule problem, people are using teleport for the quests and a LOT of them. In theory, they could be using 8 of them, which helps explain some of the impossible sounding times. If you have a pin or two, try it out next time and see if it helps. Certainly helped me, provided you can judge quickly enough whether it's time efficient to use it.

Disney Dreams
06-09-2006, 12:53 AM
SorcererDonald - interesting. That HAS to be how amazing unfathomable times are being made.

Seems there are some "professional questers" out there. Funny me - I do it for the fun (and the hope and dream of a prize).

Thanks for the above. I did find it interesting.